Wärmebrücken & Dampfdiffusionsbrücken Programm AnTherm Version 6.115 - 8.133 

[ ← ] [ ↑ ] [ → ] [Inh]

Periodic / Harmonic Data Editor Form

Das Fenster "Periodic / Harmonic Data Editor" ermöglicht es, periodische Klimadaten zu erstellen und zu bearbeiten. Diese dienen als Randbedingungen für die instationäre Auswertung.

TRANSIENT-Option: Das Lösen und Auswerten von zeitabhängigen dynamischen, periodischen Problemen, bei denen es auf Wärmekapazitätseffekte ankommt, ist nur mit aktiver TRANSIENT-Option möglich. TRANSIENT-Option in AnTherm

Der "Periodic / Harmonic Data Editor" wird aus dem Fenster Randbedingungen heraus aufgerufen, wenn instationäre Probleme ausgewertet werden sollen und dafür zeitabhängige Randbedingungen benötigt werden. Um periodische Datensätze komfortabel zu handhaben, kann er auch aus dem Menü Werkzeuge heraus aufgerufen werden.

Folgende Datentypen können mit dem Periodic / Harmonic Data Editor verwendet werden:

  • Constant (Konstante)
  • Regular Points (Reguläre Punkte)
  • Regular Means (Reguläre Mittelwerte)
  • Irregular Means (Irreguläre Mittelwerte)
  • Irregular Steps (Irreguläre Schritte)
  • Harmonic Coefficients (Harmonische Koeffizienten).

Das Fenster

Das Fenster besteht aus drei Teilen:

  • Datei-Menü
  • Information
  • Graph
  • Datensatz

Periodic Data Editor - Datei-MenüDatei-Menü:

  • New (Neu) - erstelle einen neuen Datensatz für den bestimmten Teil. Ein Dialog wird angezeigt und stellt die Information für den bestimmten Typ zur Verfügung (siehe "Information").
  • Open/Save/Save As... (Öffnen/Speichern/Speichern unter...) - ermöglicht Dateizugriffe auf die Daten (.PeriodicData, .ConstantValuePeriodic, .RegularPointsPeriodic, .IrregularStepsPeriodic, .IrregularMeansPeriodic, .RegularMeansPeriodic, .HarmonicPeriodic,)
  • Convert To... (Konvertieren...) - ermöglicht einfache synthetische Umwandlungen ausgewählter periodischer Datentypen ineinander.

Informations-Teil:

Der Informations-Teil zeigt die charakteristischen Informationen für den Datensatz an, der gerade bearbeitet wird. Abhängig vom Datentyp werden verschiedene Informationen angezeigt und zur Bearbeitung freigegeben.
Die Anfangswerte werden beim Anlegen des Datensatzes (Datei->New...) bereitgestellt. Ein begrenzter Teilsatz, abhängig vom Datentyp, kann später verändert werden.

  • Description identifying the data (Beschreibung der Daten)
  • Period Length in seconds (Periodenlänge in Sekunden)
  • Number of Intervals (Anzahl der Intervalle)
  • Number of Points (Anzahl der Punkte)
  • Interval Duration in seconds (Intervalldauer in Sekunden)

Graph:

Der Graph repräsentiert die Eingabedaten und stellt sie dar, verbunden mit dem Ergebnis einer harmonischen Fourier-Analyse und -Synthese.

Es ist möglich, mit dem Lasso zu zoomen, indem man mit der linken Maustaste in den Graphen klickt und den Zeiger zu einer anderen Stelle zieht. Mit der rechten Maustaste ist es möglich, den Zoom zurückzusetzen.

Die Legende ermöglicht die Identifizierung der gezeigten Muster. Ein Doppelklick auf die Legende wird ihre Position relativ zur Fläche ändern (rechts, links, oben, unten).

Es können auch Datenpunkte ausgewählt werden.

Datenpunkte können auch gezogen werden, um die Werte zu ändern (falls ein Abbruch gewünscht ist, drücke man auf ESC).

MULTICORE-Option: ermöglicht es, umfangreiche Rechenprozesse zu beschleunigen, indem sie auf mehrere Prozessoren aufgeteilt und parallel berechnet werden. MULTICORE Option in AnTherm

Periodic Data Editor - Chart Context MenuKontextmenü des Graphen:

  • Reset Zoom (Zoom zurücksetzen)
  • Zoom enabled (Zoom aktiviert)
  • Zoom X only enabled (Zoom nur auf X-Achse aktiviert)
  • Appearance (Erscheinungsbild)
  • Page Setup... (Seitenlayout...)
  • Preview... (Vorschau...)
  • Print... (Drucken...)
  • Copy (Kopieren)
  • Export Image... (Bild exportieren...)
  • Show synthetic data (Synthetische Daten anzeigen)
  • Window Function (Fenster-Funktion)
  • Cut-Off Harmonic (Harmonischer Cut-Off)

 

Window Function (Fenster-Funktion)
(Gibbs Effect)
Auswahl einer Filterfunktion, um den Gibbs-Effekt zu reduzieren (der auftreten kann, wenn man mit "IrregularIntervalSteps" oder mit dichten Datensätzen und einer großen Variabilität der Werte arbeitet).
  • Fejer window
  • Hann window
  • Hamming window
  • None (Keine)
Cut-Off Harmonic (Harmonischer Cut-Off) Beschränkt die Anzahl der Harmonischen für die Fourier-Synthese.

Datensatz-Teil:

Periodic Data Editor - Datensatz-MenüDie Daten werden in die Spalte "Value" eingefügt.
Es ist möglich, ausgewählte Zellen zu kopieren und einzufügen.

Die Möglichkeit, Daten aus der Spalte "Value" hinauszukopieren oder Daten in diese Spalte hineinzukopieren, vereinfacht die Dateneingabe (auch möglich via Kontextmenü). Alle Zahlen im Puffer (unabhängig davon, ob Spalten oder Zeilen) werden als doppelte Größen ausgewertet (fehlerhafte Größen und solche, die nicht ausgewertet werden können, werden ignoriert) und in richtiger Reihenfolge auf die Spalte "Value" übertragen.


 Wärmebrücken in 2D und 3D berechnen und untersuchen mit AnTherm®  

[ ← ] [ ↑ ] [ → ] [Inh

 Copyright © Kornicki Dienstleistungen in EDV & IT

2017-03-22 12:04 +0100