Wärmebrücken & Dampfdiffusionsbrücken Programm AnTherm Version 6.115 - 8.133 

[ ← ] [ ↑ ] [ → ] [Inh]

Das Arbeiten mit den Dateien

Das Programm speichert sowohl vom Benutzer eingegebene als auch aus den Eingaben errechnete Informationen in verschiedenen, projektspezifischen Dateien ab.

Projektdateien

Die Daten eines jeden Projektes werden in der sog. "Projektdatei" gespeichert. Die Projektdateien werden vom Programm mit der Erweiterung ".antherm" gespeichert. Es ist dem Benutzer in besonderen Fällen aber auch möglich, eine andere als die vom Programm vorgeschlagene Dateierweiterung (".antherm") zu verwenden.

Der Name der Projektdatei muss innerhalb jenes Verzeichnisses, in dem die Datei abgelegt wird, eindeutig sein. Es ist aber sehr wohl möglich, gleichnamige Projektdateinamen in unterschiedlichen Verzeichnissen zu verwenden.

Für die Zwecke einer Datensicherung ist es vollkommen ausreichend, die Projektdateien zu sichern. Alle für die Erstellung der Ergebnisse (ggf. für eine Neuerstellung) notwendigen Daten und alle projektspezifischen Parameter sind in der Projektdatei enthalten.

In der Projektdatei werden folgende Daten - sofern diese eingegeben wurden - abgelegt:

Die Erweiterung ".antherm" signalisiert dem Betriebssystem, dass es sich um eine Eingabedatei des Programms AnTherm handelt. Ein Doppelklick auf eine AnTherm-Projektdatei startet das Programm AnTherm und lädt die ausgewählte Datei.
Anmerkung: Auch das Abwerfen (Drag & Drop) einer Projektdatei über dem Hauptfenster des Programms öffnet dieses Projekt.

Das Öffnen oder Abspeichern von Projektdateien erfolgt durch Anwahl des Menüs "Datei". Die Projektdaten werden jedoch auch beim Beginn eines jeden neuen Rechenlaufs oder jeder neuen Auswertung automatisch gespeichert. Das Speichern von Projektdaten kann jederzeit durch Anwahl des Menüs Datei→Speichern... ausgelöst werden. Bei Auswertungen kann dies Sinn machen, um z.B. die aktuellen Randbedingungen abzuspeichern.

Das Abspeichern der Projektdaten wird durch das Programm vor jeder potentiell destruktiven Aktion automatisch angeboten, es sei denn Sie haben in den Programmeinstellungen den Parameter "Projektspeichern immer erfragen" abgeschaltet.
Es empfiehlt sich die Projektdaten vor folgenden Aktionen abzuspeichern:

Anmerkung: Beim ersten Speichervorgang legt das Programm das Standard Projektverzeichnis an und und bietet dieses als zentrales Speicherort für die Projektdateien im zugehörigen Dialog an. Die Programmeinstellung "Standard Projekteverzeichnis" legt den Namen dieses Verzeichnisses fest.

Achtung: Die Gesamtpfadlänge einer Projektdatei (also mitsamt Laufwerk und Verzeichnisangaben L:\verzeichnispfad...\projektdatei.antherm) ist bedingt durch die Betriebssystemeinschränkung begrenzt. Mit der Berücksichtigung der aktuell unter Windows herrschenden Begrenzung und Abzug der für das Simulationsverzeichnis und für die darin befindlichen Dateien notwendigen Pfadlängen, sind für die Ablage der Projektdateien insgesamt maximal 220 Zeichen erlaubt. Ist der Pfadname der Projektdatei länger als 220 Zeichen können keine Simulationsergebnisse erstellt werden - das Projekt muss unter einem anderen Namen oder in einem anderen Verzeichnis (mit gesamter Pfadlänge von weniger als 220 Zeichen) abgespeichert werden um auch die Simulationsberechung durchführen zu können.

Verzeichnis der Simulationsergebnisse

Die Zwischenergebnisse (Simulationsergebnisse) einer Berechnung eines jeden Projektes werden in einem Unterverzeichnis "<projektdatei>.dir" abgelegt.
Wird also eine Projektdatei namens <name>.antherm erstellt, so werden die Simulationsergebnisse in einem Unterverzeichnis Namens <name>.antherm.dir abgelegt. Die Projektdatei und das Unterverzeichnis der Simulationsergebnisse gehören zusammen und teilen sich aus diesem Grund den Namen.

Das Fehlen des Simulationsverzeichnisses wird durch das Programm als ein Zeichen dafür interpretiert, dass die Simulation noch nicht durchgeführt wurde. Wird das Verzeichnis <name>.antherm.dir vom Benutzer gelöscht, so wird das Programm bei der nächsten Aufforderung, die Ergebnisse des Projekts <name>.antherm anzuzeigen, den Berechnungsvorgang vollständig ausführen. Das Löschen des Simulationsverzeichnisses ist also unter anderem auch dazu geeignet, den gesamten Rechenvorgang erneut auszulösen. Da alle für die Erstellung der Ergebnisse (ggf. eine Neuerstellung) notwendigen Daten und alle projektspezifischen Parameter in der Projektdatei gespeichert sind, bedeutet der Verlust des Simulationsverzeichnisses lediglich, dass die Zeit für eine nochmalige Durchrechnung und Auswertung zu investieren ist.

Der Inhalt des Verzeichnisses der Simulationsergebnisse "<projektdatei>.dir" wird vollständig durch Programm AnTherm - für den Benutzer kaum wahrnehmbar - verwaltet. Das Verzeichnis ist ein anwendungspezifisches Arbeitsverzeichnis des Programms und ist nicht für den Zugriff des Benutzers bestimmt. AnTherm legt dieses Verzeichnis u. a. an, kann dieses aber auch inklusive sämtlicher Inhalte löschen. Aus diesem Grund dürfen im Verzeichnis "<projektdatei>.dir" keinesfalls benutzerspezifische Dateien abgelegt werden! Zudem kann eine Änderung der Inhalte der in diesem Verzeichnis von AnTherm abgelegten Dateien zu schweren Fehlern führen und ist aus diesem Grund untersagt!
Aus diesem Grund versieht AnTherm jedes Verzeichnis der Simulationsergebnisse mit dem Attribut "Versteckt" (Hidden). Dadurch sind diese Verzeichnisse im Windows-Dateiexplorer im Standardfall nicht sichtbar. Nur wenn der Benutzer die Einstellung "Versteckte Dateien anzeigen" des Windows-Explorers eingeschaltet hat, werden die Verzeichnisse der Simulationsergebnisse angezeigt. Die Einstellung des Explorers wirkt sich auch an die Anzeige des Dialogfensters Projekt Öffnen... bzw. Projekt Speichern usw.

Bemerkung: Auch die Simulationsergebnisse der Wasserdampfdiffusion werden im Unterverzeichnis DAMPF des Verzeichnisses der Simulationsergebnisse "<projektdatei>.dir" abgelegt.

Zwecks Datensicherung ist es dem Benutzer überlassen zusätzlich zu der jeweiligen Projektdatei das Simulationsverzeichnis mitzusichern. Wird die Projektdatei <name>.antherm mitsamt dem zugehörigen Simulationsverzeichnis <name>.antherm.dir wiederhergestellt, muss das Programm die Simulationsergebnisse nicht zur Gänze erneut berechnen.

Mit dem Werkzeug "Simulationsverzeichnis Bereinigung" können die Simulationsverzeichnisse gelöscht (physisch von der Platte entfernt) werden um den Speicherplatz zu sparen.

Achtung: Die Simulationsberechung eines Projektes, welches im Netzwerk via UNC Name angegeben ist (z.B. \\server\path...\project.antherm), ist nicht erlaubt. Kann der angegebene UNC-Pfad mit einer temporären Netzlaufwerkverbindung gekoppelt werden, wird dies erkannt und gemeldet. Eine Simulation auf einem Netzwerklaufwerk (über einen Laufwerksbuchstaben verbunden) ist grundsätzlich möglich obwohl (aus Performanceüberlegungen) nicht empfohlen.

Variantenrechung, Umbenennen/Kopieren der Projektdatei

Unter bestimmten Benutzungsszenarios kann es erforderlich sein, Variantenrechungen durchzuführen, die sich in Hinblick auf die Änderung von Parametern nur wenig von einander unterscheiden. Am einfachsten ist es in diesem Fall, die abgeänderte Projektdatei unter einem neuen Namen zu speichern. Dies führt jedoch auf die Notwendigkeit einer komplett neuen Simulationsberechnung, da das Verzeichnis der Simulationsergebnisse nach Änderung des Projektnamens ja noch nicht existiert.

Bemerkung: Die Notwendigkeit einer neuen Simulationsberechnung ergibt sich immer, wenn wesentliche Eingaben und Parameter des Projektes verändert wurden: z. B. die Geometrie der Baukonstruktion, die Baustoff- oder Oberflächenbeschaffenheit, die Namen (Bezeichnungen) der Räume, Wärmequellen, Oberflächen und Baustoffe, Parameter des Feinrasters usw. Dies bedeutet, dass nur in sehr seltenen Fällen eine Variantenrechung ohne neuerliche Durchführung der Simulation möglich ist.

Um Variantenrechungen durchzuführen, ohne die Simulationsberechnung nochmals (unnötig) zu starten, kann die Projektdatei mitsamt dem zugehörigen Verzeichnis der Simulationsergebnisse mit der Zuhilfenahme der Betriebssystemwerkzeuge (z.B. Dateiexplorer, Kommandofester etc.) kopiert werden.

Variantenszenario A:

Benutzen Sie Unterverzeichnisse um die Varianten dort abzulegen: kopieren Sie die Projektdatei <name>.antherm mitsamt dem zugehörigen Simulationsverzeichnis <name>.antherm.dir in ein neues Unterverzeichnis. Somit haben Sie im Unterverzeichnis "VarianteB" die gleichnamige und bereits durchgerechnete Kopie des im Verzeichnis "VarianteA" befindlichen Projektes.

Variantenszenario B:

Erstellen Sie eine Kopie der Projektdatei <nameA>.antherm und benennen Sie diese <nameB>.antherm. Erstellen Sie auch die Kopie des Simulationsverzeichnisses <nameA>.antherm.dir und benennen Sie dieses <nameB>.antherm.dir. Somit haben Sie eine exakte Kopie des Projektes "nameA" mitsamt der Simulationsergebnisse unter dem Namen "nameB" erhalten.

Sonstige Dateien

Neben den Projektdaten verwaltet das Programm weitere Informationen in weiteren, programmspezifischen Dateien:

Das Programm ist auch in der Lage Dateien, die mit anderen Anwendungen erstellt wurden, zu importieren:

Um Ihnen das Arbeiten mit dem Programm zu erleichtern, haben wir einige Beispielprojekte in der Programminstallation integriert. Diese finden Sie in dem Unterverzeichnis "Beispiele" des Installationsverzeichnisses (typischerweise ist dies C:\Programm\tkornicki\AnTherm\Beispiele) und können diese direkt über das Menü Hilfe->Beispiel Laden... im AnTherm öffnen.

Die vom Programm erstellten Ergebnisse können für eine Weiterbearbeitung exportiert werden:

Siehe auch: Das Hauptmenü, Tutorials und Kochbücher, Simulationsverzeichnis Bereinigung


 Wärmebrücken in 2D und 3D berechnen und untersuchen mit AnTherm®  

[ ← ] [ ↑ ] [ → ] [Inh

 Copyright © Kornicki Dienstleistungen in EDV & IT

2017-03-22 12:04 +0100